Version warning: Imagick was compiled against Image Magick version 1654 but version 1650 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0 [Solucionado]

Después de actualizar la versión de PHP a 7.4, apareció este error:

PHP Warning: Version warning: Imagick was compiled against Image Magick version 1654 but version 1650 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0

Como estoy usando un hosting compartido, es imposible entrar en modo root y arreglarlo recompilando o cambiando la versión de Image Magick.

Mi proveedor dijo que era imposible cambiar la versión ya que los cambios afectarían al resto de cuentas clientes.

La solución

Sin embargo, hay una forma de detener la comprobación de la versión de Image Magick, y solo agregando en php.ini con la siguiente línea:

imagick.skip_version_check=true

Debe estar guardado en el nivel más alto posible del alojamiento. Esto evitará la comprobación de la versión de Image Magick.

Etiquetado: / / / / / / / / / /

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

A %d blogueros les gusta esto: